
 

s@lm@n 

 

Lotus 
Exam 190-951

 

IBM Lotus Notes Domino 8.5 Application Development Update.
 

Version: 5.0

 

[ Total Questions:   120 ]

https://certkill.com

http://certkill.com
http://certkill.com


Topic 0, A
A 

Lainey has recently upgraded to Notes Domino 8.5. She is now exploring the design of her
applications to see what new features might be available. What is the purpose of the
controls palette that Lainey sees?
 
A. The controls palette contains controls, such as Edit Box, File Upload, and Table that the
developer can drag onto the XPage canvas. 
B. The controls palette is another way to access the same items that are available from the
Create menu for forms, views, XPages and other 
design elements. 
C. The controls palette contains items like Edit Box, Button, and Label that the developer
can drag onto XPages and forms. The controls palette 
is not available for views and pages. 
D. The controls palette contains UI and other controls (such as Button, Link, and Image)
that allow the developer to drag controls onto XPage or 
page elements. The controls palette is not available for other elements. 
 

Answer: A

 

 

Virginia is writing JavaScript code in the onclick event of an image, but she isn't seeing any
code completion from the editor. How can she get a JavaScript editor that includes code
completion?
 
A. Press Control+Spacebar to trigger code completion. 
B. Change the Eclipse preferences to include code completion in every JavaScript editor. 
C. Create the JavaScript code as a JavaScript library, then include that library in her
XPage. 
D. Click the Open Script Dialog button to open the modal JavaScript editor, which features
code completion. 
 

Answer: D

 

 

Cade is building an XPage for the Sales application. What are the options from which he
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can select when defining a data source from the data palette?
 
A. @DbLookup and @DbColumn 
B. Domino view and Domino document 
C. Data connections and DB2 access views 
D. Data connections, DB2 access views, and file resources 
 

Answer: B

 

 

Odette is designing the index XPage that is used for navigation for her Domino application.
For what purpose might Odette use the Outline view in Domino Designer in Eclipse while
working with the index XPage?
 
A. To drag elements to rearrange sections and change the sequence of elements on the
XPage. 
B. To drag controls from the controls palette onto a hierarchical representation of the XML
source code, typically during the initial design of the 
XPage. 
C. Aside from the expand and collapse icons, nothing in an Outline view is clickable.
Nonetheless, the Outline view provides an extremely useful 
means to browse the XML elements of an XPage. 
D. The Outline view provides a hierarchical representation of the XML source code in
XPages. The developer can quickly update various 
settings from within the Outline view using right-click menu options for each element. 
 

Answer: A

 

 

Devin has been developing an application that includes an XPage. When he opened the
application in Designer this morning, he noticed a small "x" icon by the XPages listing in the
Applications view. He had closed several of the Eclipse views yesterday, and does not see
any errors displayed in the remaining views. How can Devin locate the problems in the
source code?
 
A. Right-click the "x" icon from the Applications view and select Go To Error. The Problems
view displays with the cursor at the first error. 
B. Display the Problems view by selecting Window > Show Eclipse Views > Problems.
Right-click a displayed error and select Go To. The 
Source view opens to the line with the error. 
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C. Click to expand the XPages listing. A small "x" icon displays by the XPage with the
errors. Double-click the name of the XPage and the Source 
view opens to the line with the error. 
D. Click to expand the XPages listing. A small "x" icon displays by the XPage with the
errors. Double-click the name of the XPage. The Source 
tab opens with the cursor at the first error line. 
 

Answer: B

 

 

Matthew is designing an XPage with many different controls nested within each other. How
can he see the hierarchical relationship of all the controls and also be able to rearrange
them?
 
A. Using the Outline view 
B. Using the Source tab of the Editor view 
C. Under the XPages section in the application navigator. 
D. Using the Java perspective to access the raw XML files behind the application. 
 

Answer: A

 

 

Ursula has been working today on several applications. She has just reopened Domino
Designer and sees only the Marketing applications listed in the pane on the left, but does
not see the Brainstorm application that she'd been working on. What might Ursula do to
again display the Brainstorm application with the other displayed applications?
 
A. From the menu bar, click Project > Show Recent Projects. 
B. From the menu bar, click File > Application > Show All Applications. 
C. Click the menu icon from the application navigator and select Show Active Projects. 
D. Click the folders icon on the application navigator menu bar and select Show Recent
Applications. 
 

Answer: D
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Darren is working with the Outline view on a new XPage. He drags a button control so that
it is above an edit box control. What effect does this have on the XPage in the Design
editor?
 
A. The button control will move above and to the left of edit box control. 
B. There will be no effect until Darren saves the Xpage, then the button control will move
above and to the left of edit box control. 
C. There will be no effect until Darren clicks the Synchronize Navigator with Editor tab in
the application navigator, then the button control will 
move above and to the left of edit box control. 
D. There will be no effect until Darren clicks the Synchronize Navigator with Editor tab in
the Outline view, then the button control will move 
above and to the left of edit box control. 
 

Answer: A

 

 

Carlos added an edit box control to his registration XPage. He wants to make the field a
required field with a message displaying to the user if the field is left blank. Where would he
add these additional features to the edit box control?
 
A. Editor 
B. Events view 
C. Properties view 
D. Controls palette 
 

Answer: C

 

 

Joshua would like to have a cookie set on his Movie Rental XPage before it loads on the
browser. Which view would Joshua use to add this functionality?
 
A. Events view 
B. Controls view 
C. Properties view 
D. Applications view 
 

Answer: A
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Emma needs to trap and prevent certain keystrokes in her XPages application. Where can
she do this?
 
A. In the Events view 
B. In the Editor view 
C. In the Ouline view 
D. In the Properties view 
 

Answer: A

 

 

Gavin is working in Designer and wants to access the online help to answer a question.
How would he launch the Eclipse-based version of the help information?
 
A. Project > Help 
B. Navigate > Help 
C. Help > Help Contents 
D. Tools > Designer Help 
 

Answer: C

 

 

Eniola is creating a Domino Web application. She is going to try using the built-in editors for
HTML and CSS to edit some imported HTML files and to create the stylesheet. What can
Eniola do to get context-sensitive assistance from the editors?
 
A. Simply begin typing. The auto-complete feature displays a selectable list of items based
on context and on what characters have already 
been typed. 
B. At any time while editing an HTML file or a stylesheet, right-click and select from the list
of tags, attributes, and so on as appropriate for the 
current cursor location. 
C. Click File > Preferences > Domino Designer. Enable the Content Assist option to enable
auto-complete. This feature is disabled by default in 
the Eclipse environment. 
D. At any time while editing an HTML file or a stylesheet, select Edit > Content Assist or
press Ctrl+Spacebar to display a selectable list of tags, 
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attributes, and so on as appropriate for the current cursor location. 
 

Answer: D

 

 

Abbas has imported the screen.css stylesheet into his application. He has discovered that
he needs to edit the properties of some of the classes in the CSS. What steps can he
follow to make the needed changes and save the CSS changes within the application?
 
A. From the application navigator in Designer, expand Resources and expand Style
Sheets. Double-click screen.css to use the built-in CSS 
editor. 
B. From the application navigator in Designer, expand Resources and expand Style
Sheets. Click screen.css and in the Outline view select a 
class to use the built-in CSS editor. 
C. From the application navigator in Designer, expand Resources and double-click Style
Sheets. Select screen.css in the Design pane. From 
the Design tab of the Properties view, double-click a CSS class to edit its properties. 
D. From the application navigator in Designer, expand Resources and double-click Style
Sheets. Select screen.css in the Design pane. From 
the Web Properties tab of the Properties view, double-click a CSS class to edit its
properties. 
 

Answer: A

 

 

In the Reservations application, the field name for the item that stores the name of the
requester has been changed from RequestedBy to ReservedBy, and the field name for this
person's phone number has been changed from RequestedByPhone to
ReservedByPhone. The views of the application still reference the old field names, and
some of the column titles use Requested, while others use Reserved. How can Colby
update the view to use the new field name and the updated title?
 
A. Select Tools > Edit Attributes. For Type, specify Views. Select the views to modify.
Select Titles and Column Values, type "Requested" for 
Find, and "Reserved" for Change to. 
B. Select Tools > DXL Utilities > Transformer. For Type, specify Views. Select the views to
modify. For Transform what, select Column > All > All. 
Enter "Requested" for the Locate parameter, and enter "Reserved" for Transform value. 
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C. For each view, select the view in the application navigator. Select Tools > Edit
Attributes. Select Edit > Find/Replace. For Find specify 
"Requested." For Replace specify "Reserved." Click Verify Replace to confirm each
replacement as the original string is located. 
D. For each view, select the view in the application navigator. Select Tools > Edit with DXL.
After the design opens, select Edit > Find/Replace. 
Specify "Requested" for Find and specify "Reserved" for Replace. Click Find and then
Replace to visually verify each replacement. 
 

Answer: D

 

 

Percy has written a LotusScript agent that creates a vCard and attaches it to a selected
Person record in the Domino directory. His agent runs to completion, but when he opens
the document it does not have the vCard attached. Given the following LotusScript code,
what is the cause of the problem? 
 
 
  Dim session As New NotesSession 
 
  Dim dbNAB As NotesDatabase 
 
  Dim docNAB As NotesDocument 
 
  Dim dcNAB As NotesDocumentCollection 
 
 
  Set dbNAB = session.CurrentDatabase 
 
  Set dcNAB=dbNAB.UnprocessedDocuments 
 
  Set docNAB = dcNAB.GetFirstDocument 
 
 
  Do While Not (docNAB Is Nothing) 
 
    Call docNAB.AttachVCard(docNAB) 
 
    Set docNAB = dcNAB.GetNextDocument(docNAB) 
 
  Loop
 
A. The agent doesn't save docNAB after attaching the vCard. 
B. The AttachVCard method cannot use the same document object as both source and
target documents. 
C. The AttachVCard method requires an additional parameter, specifically a

Question No : 16  - (Topic 0)

Lotus 190-951 : Practice Test

8https://certkill.com

http://certkill.com
http://certkill.com


ForceDocumentSave boolean value. 
D. The AttachVCard method can only be used with mail memo documents as the target, so
the agent would have to call docNAB.Send to attach 
the vCard. 
 

Answer: A

 

 

Meegan created an image resource set for her Web application that consists of four images
placed horizontally. What are the four states that cause each of the images to show on the
screen?
 
A. link, visited, hover, active 
B. normal, click, mouse-over, blur 
C. onLoad, onFocus, onBlur, onUnload 
D. normal, mouse-over, selected, mouse-down 
 

Answer: D

 

 

Elizabeth is modifying the Customers composite application. She needs to add code to
determine if the RecentOrders component can be repositioned. What is a function she
could use for this purpose?
 
A. @IsMoveable("RecentOrders") 
B. @GetComponentProperty(MOVEABLE) 
C. @ComponentProperty("RecentOrders"; MOVEABLE) 
D. @GetComponentViewPreference(com.ibm.rcp.moveable) 
 

Answer: D

 

 

Ignacio needs to enable rich text editing in his Web application. He would like to take
advantage of the Dojo rich-text editing control available in XPages, but he needs to use it
on a form instead. How can he do this task?
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A. Select Using JavaScript Control on the rich text field's Web Access Display property. 
B. Create an otherwise blank XPage with a rich text editing control and use pass-through
HTML to include that XPage within the form. 
C. The only way to do this task is to set up a separate Dojo installation within his
application; Ignacio cannot access the Dojo libraries used in 
XPages. 
D. Create a temporary XPage with a rich text editing control, then go to the Source tab and
copy the XML for the rich text control and paste it 
onto the form. 
 

Answer: A

 

 

Jeff is setting up his status XPage so that it displays graphical status indicators based on
the data being displayed. He has not received the images from his customer yet. What can
he do to continue developing the application while waiting for the images to be delivered?
 
A. Select the null image when adding the image control to the form. 
B. Select Use an image placeholder when adding the image control to the form. 
C. Select the placeholder image from Image Resources in the application navigator. 
D. Select the Determine Later option when adding the image control to the form. 
 

Answer: B

 

 

Kumar is building the XPage that serves as the home page for the Corporate Happenings
site. The home page needs to include an image at the top right of the page, and this image
changes weekly. How can Kumar design his XPage to do a lookup to the vConfig view to
determine the location of the image, rather than hard-coding an image URL?
 
A. Drag a computed field control onto the XSP editor. Select Formula language for the
Data Binding. Enter this code in the script pane: 
"<image src=\""+@DbLookup(\"\";\"vConfig\";\"spotlightImage\";1)+"\" />" 
B. Drag a computed field control onto the XSP editor. Select Formula language for the
Data Binding. Enter this code in the script pane: 
"<image src=\""+@DbLookup(\"\",\"vConfig\",\"spotlightImage\",1)+"\" />" 
C. Drag an image control onto the XPage. Select Use an image placeholder. For the Image
source property, select the Computed property 
button. Enter this code for the script: 
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